Waarom is er een WordPress 4.1.3 update ?

Sinds de WordPress 4.2 update is uitgerold gisteren, krijgen we vragen van gebruikers waarom hun website automatisch is geupdate naar WordPress 4.1.3.  Over de release was nog geen informatie te vinden op de Make WordPress Core site of the officiele nieuwsblog van WP. Echter in dit artikel (in het Engels) is wel een uitleg te vinden.

Fix database writes for esoteric character sets, broken in the WordPress 4.1.2 security release. Neither UTF-8 nor latin1 were affected. For more information, see ticket #32051.

Het ticket bevat een lange technische uitleg van een fatale bug en wat er gedaan is om deze te verhelpen. De patch om de bug op te lossen is vervolgens toegevoegd aan de volgende versies

  • 3.7.7
  • 3.8.7
  • 3.9.5
  • 4.0.3

Aangezien dit kleine releases zijn, zullen sites vanaf versie 3.7 automatisch geupdate worden, tenzij de server dit niet ondersteund of de auto update is uitgeschakeld. Heb je nog een oudere versie van WordPress draaien dan raad ik je ten zeerste aan te updaten naar versie 4.2. Niet alleen heeft het een aantal verbeteringen maar er zijn ook 231 bugs in opgelost.

 

Comments

Add a comment

mood_bad
  • No comments yet.
  • chat
    Add a comment
    keyboard_arrow_up